News:

Willkommen im Notebookcheck.com Forum! Hier können sie über alle unsere Artikel und allgemein über Notebook relevante Dinge disuktieren. Viel Spass!

Main Menu

XPR17E20: Default Boot Device Missing or Boot Failed

Started by LastOfTheMohicans, May 16, 2022, 21:23:39

Previous topic - Next topic

LastOfTheMohicans

Hallo.

Mein System: XPR17E20 mit Windows 11 Pro; 2 x 16 Gb Ram, 2 identische Samsung M2 500 Gb SSDs mit RAID 0 als Systemlaufwerk, eine 1 TB Crucial SSD für Daten (habe ich gestern nach dem erstmaligen Auftauchen der im Folgenden beschriebenen Probleme vorerst ausgebaut);
Bios Updates habe ich Oktober 2021 das letzte Mal gemacht. Version siehe Bild.

Seit gestern bekomme ich bei jedem Start (wenn der Rechner davor einige Zeit aus war) die Fehler in den Screenshots nachdem der Rechner nach dem Einschalten mehrmals kurz anläuft und neu startet. Ein unmittelbarer Neustart, wenn das Gerät mal läuft, scheint aber bislang zu funktionieren.

"Default Boot Device Missing or Boot Failed..." bzw.
"CMOS Message - A first boot or NVRAM reset condition has been detected...".

Das Problem begann gestern (15.5.2022) am Abend, als ich den Rechner eingeschaltet habe und er mehrmals für ein paar Sekunden anlief aber der Bildschirm schwarz blieb, sich ausschaltete und wieder startete. Nach ein paar Anläufen kam schließlich eine der Fehlermeldungen oben (ich glaube es war "CMOS Message ...".
Klick auf OK startete den Rechner nochmal, diesmal mit der zweiten Meldung.
Klick auf OK brachte mich dann ins BIOS.

Ich stellte dann gestern nach diesen erfolglosen Starts und ebenso erfolglosen Versuchen, das BIOS zurückzusetzen oder mit einem Windows 11 Boot Stick etwas auszurichten im BIOS fest, dass als SATA Mode AHCI und nicht mehr RST Premium... konfiguriert war.

Nachdem ich wieder RST Premium eingestellt hatte, startete der Rechner allerdings weiterhin nicht und ich stellte im BIOS im Advanced - Rapid Storage ... Bereich fest, dass dort ein Eintrag mit RAID 0 "FAILED" ausgewiesen war.

Mit der Erkenntnis, dass ein "Failed"-Status ohnehin den Verlust aller Daten in einem RAID-0-Verbund bedeuten dürfte, habe ich dann erstmal meine Datenplatte ausgebaut und RAID im BIOS gelöscht und versuchsweise neu mit den beiden vorhandenen Platten angelegt.
Das hat auch problemlos funktioniert, Windows 11 hat die Platte in üblicher größe von etwa 950 GB erkannt und ließ sich installieren. Der Rechner lief dann auch soweit.

chkdsk, sfc scans haben nichts angedeutet, was irgendwie darauf hindeuten würde, dass möglicherweise eine der beiden SSDs defekt sein könnte (war zumindest meine erste Vermutung). Die Neustarts gestern während der Installation hat das System auch ohne weitere Probleme weggesteckt.

Heute 16.5. einen Tag später nach dem Einschalten wieder selbes Problem. Erst mehrmalige Anläufe, dann CMOS-Fehlermeldung, dann "Default Boot Device Missing...".
Im BIOS dann wieder SATA Mode auf AHCI.

Wieder auf RST umgestellt, startete der Rechner dann auch normal ins Windows, ließ sich auch Neustarts im Zuge von Updates gefallen.
Etwa eine Stunde ausgeschalten, wieder gestartet und selbige Probleme.
Auch diesmal klappte der Start dann aber wieder, nachdem ich AHCI wieder auf RST umgestellt hatte.

Aktuell sehe ich keinen Grund einer defekten Platte. Ist das Motherboard möglicherweise defekt?
Jedenfalls habe ich jetzt mal die CMOS-Batterie ausgetauscht.

So alt wäre das Gerät ja noch nicht.

Besten Dank!

Rob

XMG Community

Vielen Dank für den ausführlichen Bericht. Einen SSD-Defekt würde ich zwar nicht ausschließen, aber dass das BIOS sich von IRST auf AHCI zurücksetzt, ist schon ein wenig verdächtig.

Es bleibt abzuwarten, ob das Problem nach dem Wechsel der CMOS-Batterie noch einmal auftaucht.

Ansonsten würde ich nochmal das BIOS aktualisieren, da es im Dezember 2021 nochmal ein Update gab:

https://download.schenker-tech.de/package/xmg-pro-17-xpr17e20/

Vor dem BIOS-Setup bitte MESET.efi ausführen, damit beim BIOS auch die Intel "ME" aktualisiert wird, welche eventuell mit Software-RAID zusammenhängt.

Schau bitte auch, ob deine EC-Firmware aktuell ist.

Neugierige Frage: wieso RAID 0? Lohnt sich für den Gewinn an sequentieller Datenrate der mögliche Verlust an Latenz bzw. IOPS? Kommt sicherlich auf den Einsatzzweck an. Ich frage nur, weil ich freiwillige SSD-RAID-0-Verbunde (wo es nicht bereits vom OEM vorkonfiguriert ist), recht selten in freier Wildbahn sehe.

VG,
Tom
Schenker Technologies GmbH
// Firmenaccount für PR & Communitypflege
Technical Support
Mo-Fr 8-18 | Sa 9-14 // Tel.: +49 341 246704-0

LastOfTheMohicans

#2
Guten Morgen Tom,

danke für deine Antwort.

Ob das Wechseln der Batterie etwas gebracht hat, kann ich erst heute Abend prüfen.
Meine installierten BIOS/EC Versionen 1.07.10 und 1.07.05 decken sich aber mit denen im Download-Center. Hab da vielleicht ohnehin später nochmal ein Update gemacht, das ich grad nicht mehr im Kopf habe. :)

Du hast aber glaub ich in einem früheren Thema schon mal geschrieben, dass es manchmal auch nicht schadet, die selbe Version noch mal zu flashen. Kann ich ja heute abend dann mal machen

Ob die chkdsk Prüfungen konkret etwas gefunden haben muss ich auch erst im Protokoll nachschauen. Laut SMART sind beide Platten good.

Das RAID 0 war eigentlich reine Spielerei und Neugier, weil ich gerade eine baugleiche SSD verfügbar hatte, wie sie im Gerät damals geliefert wurde und ich eben wusste, dass manche OEM solche Konfigurationen anbieten.
Nachdem mit der Einrichtung und im Betrieb alles einwandfrei geklappt hat, habe ich es zugunsten des größeren Platzes mal dabei belassen, mit dem Bewusstsein, dass der Ausfall einer Platte dann den kompletten Datenverlust bedeutet.
Da ich mir das Backup einer Systempartition dann meistens auch spare, nutze ich die Zeitpunkte dann für eine frische Installation.

Sollte sich eine der beiden Platten doch noch als defekt rausstellen, steige ich sowieso wieder auf eine einzelne Platte um.
Für ein neues System würde ich RAID 0 ohnehin nicht mehr in Betracht ziehen. Aber momentan hab ich für die zweite SSD keine andere Verwendung. :)

Danke
bg
Rob

Nachdem ich als langjähriger Kaspersky-Nutzer aus bekannten Gründen heraus mal angefangen habe, Alternativen zu evaluieren, hatte ich jetzt grade mal McAfee im Einsatz. Irgendwie ist dieses Tool noch genau so ein Rotz wie vor 20 Jahren. Dass die Probleme am PC gerade jetzt auftauchen, wo McAfee drauf läuft, ist vermutlich nur reine Koinzidenz... ein Schelm...  >:D


LastOfTheMohicans

#3
Also erster Start am Abend heute (17.5.) war erfolgreich. Keine Probleme.
Vielleicht doch die Batterie?

Werde mal nicht zu viel installieren, falls sich doch noch eine Platte als schadhaft entpuppen sollte.
BIOS/EC habe ich nochmal eingespielt.


Seltsames Dingens dann später: Das Gerät lief mit der neuen Installation soweit einwandfrei, Treiber alles ok. Keine Anzeichen für Fehler.
Schließlich wollte ich noch die Intel RST Software installieren, aber das war es dann. Danach wollte das Gerät wieder nicht mehr starten.
Allerdings nicht mit dem oben beschriebenen Verhalten und den geschilderten Fehlern.
Nach dem Neustart erhielt ich jetzt einen BSOD mit INACCESSIBLE_BOOT_DEVICE.
Die Windoswreparatur versagte allerdings auch hier. Im BIOS aber war alles beim Alten. SATA Mode war RST und die RAID Platte war auch nicht irgendwie FAILED oder so.

Im Netz bin ich dann darauf gestoßen, dass besagter BSOD offensichtlich des öfteren mal bei Installationen von Intel RST passieren kann. Die Lösungsansätze habe ich jetzt allerdings nicht verfolgt.

Ich bin jetzt auf einzelne Platte umgestiegen. Falls eine davon defekt ist, sollte sich das so ja rausfinden lassen.
Habe die jetzt freie der beiden Samsung SSDs auch gleich mal gecheckt. Also laut chkdsk und SMART auf der Platte alles ok. Auch keine fehlerhaften Sektoren oder so. Aufgrund der älteren Firmware ist das wohl auch die, die ich zusätzlich installiert hatte.
Die andere Platte auf der das System jetzt installiert ist, ist laut chkdsk und SMART aber ebenfalls ok.


Mal noch ne andere Frage nebenbei: Bringt das Over Provisioning noch irgendwas? Sollte man das machen? Macht das Sinn wenn ich die SSD ohnehin nicht bis zum Anschlag fülle?

Danke
bg
Rob

XMG Community

Intel RAID geht m.E. auch ohne die Installation der Intel IRST-Software. Einfach im BIOS einrichten, fertig.

Andererseits ist RAID 0 auf SSDs einfach weder Mühe noch Risiko wert, wie du ja jetzt auch festgestellt hast.

Spontane SSD-Defekte lassen sich nicht immer mit chkdsk oder SMART absehen. Wenn die Platte alle paar Wochen einfach mal einen Aussetzer hat, dann wird sich das nicht vorher in SMART-Telemetrie oder defekten Sektoren ankündigen. Diese ganzen Methoden stammen noch aus der mechanischen Welt der Festplatten, wo Verschleiß graduell und analog einsetzt.

Overprovisioning bzw. die SSD nicht bis zum Anschlag fühlen bringt etwas, ja. Es erhöht die SSD-Schreib-Performance und erleichtert das Wear-Leveling, also das Umschaufeln von Daten auf weniger verbrauchte Zellen.

VG,
Tom
Schenker Technologies GmbH
// Firmenaccount für PR & Communitypflege
Technical Support
Mo-Fr 8-18 | Sa 9-14 // Tel.: +49 341 246704-0

LastOfTheMohicans

#5
Ja, ginge auch ohne. Weiß nicht, welcher Wahnsinn mich geritten hatte, das wieder zu installieren.  :D

Ist halt der Nachteil von SSDs. Man hört nichts mehr.  >:D

Aber egal. Ich habe das System jetzt zwei-, dreimal neu eingerichtet und bin damit jetzt wieder auf eine einzelne Platte umgestiegen, benutze die andere mal im selben PC für nebensächliche Daten.

Mal sehen, ob sich eine der Platten in nächster Zeit wieder mit Problemen bemerkbar macht. Bislang läuft jetzt alles einwandfrei.
Habe auf den Samsung-Platten jetzt auch Over-Provisioning eingerichtet.
Leider scheint das Crucial Tool Probleme zu haben, meine Crucial Platte zu erkennen, obwohl sie überall sonst aufscheint. Wird vermutlich meine erste und letzte Crucial SSD gewesen sein...

Und nur falls es von Interesse ist: Mein Batterietester bleibt bei der rausgenommenen Batterie übrigens komplett schwarz. Lustig, so viel Saft kann das Licht am Tester nicht brauchen, dass da gar nichts aufleuchtet, außer die Zelle ist komplett hinüber.  ???

Danke jedenfalls.

bg
Rob

Quick Reply

Name:
Email:
Verification:
Please leave this box empty:

Shortcuts: ALT+S post or ALT+P preview