Notebookcheck

Autor Thema: Linux-Sammelthread  (Gelesen 84261 mal)

XMG Community

  • Schenker Staff
  • High End NB
  • *
  • Beiträge: 4217
  • Karma: +249/-38
  • Offizieller XMG Forensupport
Re: Linux-Sammelthread
« Antwort #150 am: Februar 20, 2019, 15:52:10 »
Hallo udo,

ich hab mal unsere Linux-Experten bei Tuxedo gefragt, ob die eine Idee haben.
Den Lösungsvorschlag teile ich dir dann gleich mit :)

Gruß
XMG|Arthur
Schenker Technologies GmbH
// Firmenaccount für PR & Communitypflege
Technical Support
Mo-Fr 8-18 | Sa 9-14 // Tel.: +49 341 246704-0

Udo

  • Gast
Re: Linux-Sammelthread
« Antwort #151 am: Februar 20, 2019, 22:14:10 »
Hallo,
ich habe mittlerweile ziemlich viel im Internet quergelesen. Also, so wie es aussieht, scheint ein Booten von NVME bei keinem Hersteller ab Werk zu funktionieren. Selbst Windows nutzt den Umweg über den Bootsektor von der sda (Sata SSD) Partition. Ein direktes Booten von NVME Laufwerkern wird auch dort nicht gemacht, weil es vom Bios schon gar nicht geht.
Ich könnte nun, auf der als SSD angebundenen und nur mit Sata Geschwindigkeit laufenden M.2 Karte im Bootsektor Grub so konfigurieren, dass Linux auf der NVME läuft, aber wenn diese M2 SSD den Bootsektor gelöscht bekommt , muss ich wieder fummeln.
Aus dem Bios lassen sich nur direkt Partionen Booten, die entweder per USB eingebunden sind oder eben über Sata Protokol angesprochen werden, wie die 250gb Samsung die verbaut wurde.
Ein NVME Laufwerk wird mit dem Bios niemals als Bootlaufwerk nutzbar sein. Schade das die Schlafmützen, bei der Schnittstelleneinbindung im Bios, ein Booten nicht bedacht haben.
Trotzdem Danke für die Rückmeldung. So bleibt eine NVME als Systemlaufwerk, ein unerfüllbarer Wunsch, wenn nicht eine Sata Platte als Bootlaufwerk dient.
So bin ich immer genötigt, eine "langsame" Sata SSD zu nutzen....
Technik die begeistert....
Gruss Udo

Udo

  • Gast
Re: Linux-Sammelthread
« Antwort #152 am: Februar 22, 2019, 14:15:41 »
Hallo,
nach dem sich der Frust, das von NVME nicht direkt zu Booten ist gelegt hat, nun etwas zum Thema.
 Unter Kubuntu 18.10 läuft alles auf anhieb beim XMG Pro 17.
Solange ich nur die Intelgrafik nutze, werden die Lüfter auch kaum höhrbar gedreht.
Sobald ich die Treiber von NVidia installiere und aktiviere, wird die verbaute 1070 so warm, dass die Lüfter nervend laut werden, bis dieTemperatur wieder unter einem Schwellwert fällt und das eben alle paar Minuten. Bei Nutzung der Intelgrafikkarte bleibt der Laptop flüsterleise.
Alles im Desktopbetrieb mit Nutzung einiger verschiedener Programme.
Den Fingerabdrucksensor habe ich noch nicht versucht zu aktiviere, aber unter Linux wird der bestimmt nicht gescheit funktionieren und Windows wollte ich eigentlich meiden.
Der Akku hällt gefühlte 2 Stunden, das ist aber auch nicht so wichtig für mich.
Unter Kubuntu lief Wlan schon bei der Installation, was ich bei Windows 10 erst mühsam nachinstallieren musste.
Die Tastatur leuchtet in einem angenehmen Blau, ob unter Linux ein Farbwechsel möglich ist, werde ich in den nächsten Tagen rausfinden.
So im ganzen lässt sich angenehm mit dem Laptop arbeiten.
Gruss Udo


Udo

  • Gast
Re: Linux-Sammelthread
« Antwort #153 am: Februar 25, 2019, 20:07:49 »
Hallo,
also, bis jetzt habe ich etwas rumgespielt und einiges herrausgefunden.
Wenn die Partitionen auf der NVME vorher aufgeteilt wurden, kann man unter einer manuellen Partitionierung bei Kubuntu 18.10, die NVME als Rootlaufwerk auswählen, solange man Grub auf Sda schreiben lässt, funktioniert auch das Starten auf NVME.
Ist halt ein Umweg, den ich wohl gehen muss, wenn ich ein Systemlaufwerk mit maximaler Geschwindigkeit haben möchte.
Solange die Sda Platte kein Ausfall bekommt, ist es benutzbar.

Leider schafft Kubuntu Wlan nicht wieder aufzwecken, wenn ich den Rechner nur zuklappe. Ich muss den Laptop dann neu starten, um wieder Wlan zu haben.
Nvidia taktet die Grafikkarte leider so hoch, das es eben zu warm wird. auch wenn man nichts am Rechner macht. Ein konsequentes runtertakten wäre eine Lösung, aber so muss ich eben bei der Intelgrafik bleiben, um kein nerviges Lüfterbrausen zu haben.
Die Soundausgabe ist eher mau, da bin ich besserer bei meinem alten Asus N76vz mit Bose gewohnt.
Das Gewicht ist beim XMG wesentlich geringer. Das Display ist besser als beim Laptop von 2013.
Mal schauen ob dieser hier auch so lange hällt.
Ansonsten  funktioiniert alles was der Rechner an Schnittstellen hat unter Kubuntu 18.10
Wenn man zwischen den Laptops wechselt, merke ich doch, wie stark die Technik performater geworden ist. und eben viel weniger Gewicht hat.
Die Grafik im Asus, war eine Nvidia 635m in 40nm. Die wurde nicht so warm das Lüfter nerven, wie eine 1070 in 16nm Struktur.
Vielleicht hätte ich eine 1050 nehmen sollen, um weniger radau am Rechner zu haben. Aber ob das eine Lösung ist, kann nur ein 1050 Besitzer berichten.
Gruss Udo






Bratwurstzange

  • Gast
Re: Linux-Sammelthread
« Antwort #154 am: Mai 29, 2019, 09:37:35 »
Ich kann die Firma Tuxedo empfehlen, die haben die gleichen Geräte.

XMG Community

  • Schenker Staff
  • High End NB
  • *
  • Beiträge: 4217
  • Karma: +249/-38
  • Offizieller XMG Forensupport
Re: Linux-Sammelthread
« Antwort #155 am: Mai 30, 2019, 04:46:46 »
Können wir bestätigen.

Partnerschaftliche Grüße,
XMG|Tom
Schenker Technologies GmbH
// Firmenaccount für PR & Communitypflege
Technical Support
Mo-Fr 8-18 | Sa 9-14 // Tel.: +49 341 246704-0

Kathi

  • Netbook
  • *
  • Beiträge: 36
  • Karma: +0/-0
Re: Linux-Sammelthread
« Antwort #156 am: Juli 09, 2019, 22:46:15 »
Moin  :)

Hardware: XMG ULTRA 17

Betriebssystem: Linux Mint 19.1, aktueller Kernel (Aktualisierungsverwaltung)

Problem: Tuxedo Keyboard Modul für Tastatur Hintergrundbeleuchtung
https://www.tuxedocomputers.com/de/Infos/Hilfe-Support/Anleitungen/Tastatur-Treiber-fuer-TUXEDO-Computers-Modelle-mit-RGB-Tastatur-nachinstallieren.tuxedo

Ich bekomme das Keyboard Modul gemäß der Anleitung installiert und direkt nach der Installation ist es auch geladen und funktioniert inkl. an/aus, heller/dunkler, umschalten der einzelnen Licht-Modi.

Auch wenn ich meine Farbwahl via Terminal abschicke, wird sie in die entspr. Konfigurations-Datei eingetragen.

Nach dem Neustart allerdings wird das Tuxedo Keyboard Modul nicht mehr geladen und auch der Terminal Command von der Tuxedo Seite lädt es nicht mehr.

Das Modul ist aber vorhanden.

Ich habe das alles mal in einer Textdatei dokumentiert, die ich hier mit anhänge - inkl. Anmerkungen meinerseits in der Textdatei.

Die Anleitung von der Tuxedo Seite habe ich 2 Mal durchgeführt (ich habe eine Timeshift Sicherung zurück gespielt und es noch einmal versucht) - beide Male war es genau das gleiche Verhalten.

Wie bekomme ich das Tuxedo Keyboard Modul bei Systemstart geladen?

Es ist ja nicht so, dass es nie funktioniert hat und hinsichtlich meiner Linux-Erfahrung stehe ich ziemlich am Anfang, so dass ich das nicht durchschaue was da quer gelaufen sein könnte.

Es wäre toll, wenn mir da jemand helfen könnte.

Vielen Dank.

LG Kathi
Linux Mint 19.1 Cinnamon 64 bit, Kernel 5.0.0-20,
NVIDIA driver metapackage 430.26-0ubuntu0-gpu18.04.1

XMG ULTRA 17, Ultra HD IPS | G-SYNC
NVIDIA GeForce RTX 2070 | 8 GB GDDR6
Intel Core i7-8700, 32 GB DDR4
XMG P406 PRO
NVIDIA GeForce GTX 970M | 3 GB
Intel Core i7-6820HK, 32 GB DDR4

Kathi

  • Netbook
  • *
  • Beiträge: 36
  • Karma: +0/-0
Re: Linux-Sammelthread
« Antwort #157 am: Juli 10, 2019, 11:42:23 »
Folgende Funktionstasten funktionieren bisher unter Linux Mint 19.1 auf dem XMG Ultra 17 mit Kernel 5.0.0-20 (getestet):

Fn ^  = An-/Ausschalten der Musik, die z. B. gerade in Banshee oder Radiotray läuft

Fn F2 = Display an/aus

Fn F3 = Stummschaltung/Stummschaltung aufheben

Fn F5 / Fn F6 = Audiolautstärke verringern/erhöhen

Fn F8 / Fn F9 = Display Helligkeit verringern/erhöhen

Fn F11 = Flugzeugmodus an/aus

Fn F12 = Energiesparmodus aktivieren


Folgende Funktionstasten habe ich getestet und sie funktionieren nicht:

Fn F1 = Touchpad deaktivieren/aktivieren

Fn F10 = Kamera an/aus

Fn Tasten auf der Nummerntastatur rechts für die Hintergrundbeleuchtung der Tastatur

Fn F4 gibt es nicht mehr, war auf meinem anderen Notebook für die Helligkeit der Hintergrundbeleuchtung zuständig.

Fn F1 und Fn F10 sind mir nicht so wichtig, aber die Möglichkeit die Hintergrundbeleuchtung der Tastatur einzustellen und zu reglen schon.
Linux Mint 19.1 Cinnamon 64 bit, Kernel 5.0.0-20,
NVIDIA driver metapackage 430.26-0ubuntu0-gpu18.04.1

XMG ULTRA 17, Ultra HD IPS | G-SYNC
NVIDIA GeForce RTX 2070 | 8 GB GDDR6
Intel Core i7-8700, 32 GB DDR4
XMG P406 PRO
NVIDIA GeForce GTX 970M | 3 GB
Intel Core i7-6820HK, 32 GB DDR4

Kathi

  • Netbook
  • *
  • Beiträge: 36
  • Karma: +0/-0
Re: Linux-Sammelthread
« Antwort #158 am: Juli 10, 2019, 16:51:02 »
Hi,

nächstes Problem mit Linux Mint 19.1 und XMG Ultra 17:

Gemäß dieser Anleitung https://github.com/tuxedocomputers/tuxedo-fan-control/ habe ich versucht TuxedoFanControl zu installieren.

Bis zum Command npm install läuft auch immer alles gut, aber dann kommen folgende Meldungen:

[email protected]:~$ npm install
npm WARN saveError ENOENT: no such file or directory, open '/home/mintuser/package.json'
npm notice created a lockfile as package-lock.json. You should commit this file.
npm WARN enoent ENOENT: no such file or directory, open '/home/mintuser/package.json'
npm WARN mintuser No description
npm WARN mintuser No repository field.
npm WARN mintuser No README data
npm WARN mintuser No license field.

up to date in 0.868s
found 0 vulnerabilities

[email protected]:~$


In der package-lock.json steht dann:

{
  "lockfileVersion": 1
}

Ich komme hier leider nicht weiter. Hat vielleicht jemand eine Idee?

Danke.
Linux Mint 19.1 Cinnamon 64 bit, Kernel 5.0.0-20,
NVIDIA driver metapackage 430.26-0ubuntu0-gpu18.04.1

XMG ULTRA 17, Ultra HD IPS | G-SYNC
NVIDIA GeForce RTX 2070 | 8 GB GDDR6
Intel Core i7-8700, 32 GB DDR4
XMG P406 PRO
NVIDIA GeForce GTX 970M | 3 GB
Intel Core i7-6820HK, 32 GB DDR4

Kathi

  • Netbook
  • *
  • Beiträge: 36
  • Karma: +0/-0
Re: Linux-Sammelthread
« Antwort #159 am: Juli 11, 2019, 15:46:00 »
Ergänzung zum Thema Tuxedo Keyboard

11.07.19 13:53 CAS kernel [    3.884828] tuxedo_keyboard: loading out-of-tree module taints kernel.
11.07.19 13:53 CAS kernel [    3.884841] tuxedo_keyboard: module verification failed: signature and/or required key missing - tainting kernel
11.07.19 13:53 CAS kernel [    3.884925] tuxedo_keyboard: `#ADFF2F' invalid for parameter `color_left'
11.07.19 13:53 CAS kernel [    3.884927] tuxedo_keyboard: `#00FF00' invalid for parameter `color_center'
11.07.19 13:53 CAS kernel [    3.884928] tuxedo_keyboard: `#ADFF2F' invalid for parameter `color_right'
11.07.19 13:53 CAS kernel [    4.121009] tuxedo_keyboard: `#ADFF2F' invalid for parameter `color_left'
11.07.19 13:53 CAS kernel [    4.121011] tuxedo_keyboard: `#00FF00' invalid for parameter `color_center'
11.07.19 13:53 CAS kernel [    4.121012] tuxedo_keyboard: `#ADFF2F' invalid for parameter `color_right'
(Protokolleintrag nach Systemstart)


Aufgrund obiger Fehlermeldung habe ich es nun immerhin geschafft die Tastaturfarbe grünlich zu setzen.

So muss es dann richtig aussehen mit den Farben:

echo "options tuxedo_keyboard mode=0 color_left=0x7fff1b color_center=0x00FF00 color_right=0x7fff1b" > /etc/modprobe.d/tuxedo_keyboard.conf
Nachdem ich die Farben nun korrigiert habe, steht nach erneutem Systemstart nun folgendes im Protokoll:

11.07.19 15:36 kernel tuxedo_keyboard: loading out-of-tree module taints kernel.
11.07.19 15:36 kernel tuxedo_keyboard: module verification failed: signature and/or required key missing - tainting kernel
11.07.19 15:36 kernel tuxedo_keyboard: Model 'P7xxTM1' found
11.07.19 15:36 kernel input: TUXEDO Keyboard as /devices/platform/tuxedo_keyboard/input/input20
11.07.19 15:36 kernel tuxedo_keyboard: set_mode on CUSTOM
11.07.19 15:36 kernel tuxedo_keyboard: Set brightness on 255
11.07.19 15:36 kernel tuxedo_keyboard: Set keyboard state on: 1
11.07.19 15:36 systemd-modules-load Inserted module 'tuxedo_keyboard'

Es fehlt eine Signatur, ein Schlüssel, wie es scheint. Nur bin ich genau nach Anleitung vorgegangen. Hat jemand eine Idee was da zu tun ist?

Mit den Tasten kann ich nach wie vor die Helligkeit der Tastaturbeleuchtung nicht beeinflussen.
« Letzte Änderung: Juli 11, 2019, 15:50:23 von Kathi »
Linux Mint 19.1 Cinnamon 64 bit, Kernel 5.0.0-20,
NVIDIA driver metapackage 430.26-0ubuntu0-gpu18.04.1

XMG ULTRA 17, Ultra HD IPS | G-SYNC
NVIDIA GeForce RTX 2070 | 8 GB GDDR6
Intel Core i7-8700, 32 GB DDR4
XMG P406 PRO
NVIDIA GeForce GTX 970M | 3 GB
Intel Core i7-6820HK, 32 GB DDR4

XMG Community

  • Schenker Staff
  • High End NB
  • *
  • Beiträge: 4217
  • Karma: +249/-38
  • Offizieller XMG Forensupport
Re: Linux-Sammelthread
« Antwort #160 am: Juli 17, 2019, 15:23:55 »
Hi Kathi,

es ist leider wirklich schwierig, hier vollen Linux-Support zu geben, wenn das Gerät nicht über Tuxedo gekauft ist. Ich frage die Kollegen mal, ob deine Fehlermeldung daran liegt, dass du nicht das Tuxedo-gebrandete BIOS mit den entsprechenden DMI-Strings installiert hast. Ansonsten kannst du Fehler zu dem tuxedo_keyboard Treiber auch direkt bei Github melden.

https://github.com/tuxedocomputers/tuxedo-keyboard/issues

VG,
XMG|Tom
Schenker Technologies GmbH
// Firmenaccount für PR & Communitypflege
Technical Support
Mo-Fr 8-18 | Sa 9-14 // Tel.: +49 341 246704-0

gkn

  • Einsteiger NB
  • Beiträge: 3
  • Karma: +0/-0
Re: Linux-Sammelthread
« Antwort #161 am: Februar 25, 2020, 19:19:53 »
Ich bin seit einigen Wochen Besitzer eines XMG-Pro 17 Zoll (Modell 2019) auch das ich mein bestehendes Linux-System (Ubuntu 16) aus zeitlichen Gründen migriert habe.

Funktioniert auch alles wunderbar. Nur die NVIDIA Geforce RTX 2060 Grafikkarte und die Intel i915 GPU (Hybrid) scheinen sich so gar nicht zu mögen! Ich habe bereits die NVIDIA binary Treiber (NVIDIA-Linux-x86_64-440.59.run) probiert zu installieren. Ebenso natürlich die ubuntu Treiber - die allerdings nur in Version 430 vorliegen.

Da ich einen aktuelleren Linux 5.5 Kernel verwende, funktioniert der Treiber in Version 430 definitiv schon mal nicht (bekannter Bug wegen Kernel Unterschieden zum 4.x Kernel-Tree).

Die 440-Treiber lassen sich einwandfrei installieren (aus dem binary-Paket) und compilieren auch die Treiber. Allerdings bootet Ubuntu partout nicht in die X-Server Oberfläche!

Kaum dass ich die "NVIDIA-Linux-x86_64-440.59.run --uninstall" ausführe startet der noch im Boot-Prozess (kurz vor LightDM Display-Manager) wartende Rechner sofort mit der Intel GPU in die grafische Oberfläche. Allerdings läuft das Notebook damit eher schlecht als Recht!

Gibt es irgendwelche produktiven Vorschläge oder andere Leidgenossen?Besteht irgendeine Möglichkeit die Intel i915 GPU komplett zu deaktivieren? Am Besten im BIOS (habe leider nichts gefunden)?

Gibt es wie bei älteren Insyde-BIOS irgendeine versteckte Option für erweiterte Einstellungen?

sammo82

  • Netbook
  • *
  • Beiträge: 21
  • Karma: +2/-0
Re: Linux-Sammelthread
« Antwort #162 am: Februar 25, 2020, 20:28:52 »
Hallo, ich hatte auch so meine Probleme mit dem Grafiktreiber.

Ich habe das Neo15 mit der RTX 2070 und betreibe Manjaro, vorher Arch.
Bei mir funktioniert es bestens, seit dem ich Optimus-Manager verwende.

Was heiße denn Funktionieert nicht?
Ich hatte das Problem, dass der Monitor schwarz blieb, aber wenn ich ein HDMI-Kabel ran gesteckt habe und neu gestartet habe, kam das Bild über HDMI.

Habe es dann irgendwie geschafft umzustellen, auf den internen Monitor.
Ich glaube ich habe alle Configdateien gelöscht, die mit dem X-Server zu tun haben, damit sie neu angelgt werden.

Viele Grüße,
Sammo

gkn

  • Einsteiger NB
  • Beiträge: 3
  • Karma: +0/-0
Re: Linux-Sammelthread
« Antwort #163 am: Februar 26, 2020, 08:49:53 »
Hallo Sammo,
danke für deine Antwort.

Bei mir funktioniert es bestens, seit dem ich Optimus-Manager verwende.

Welches Tool genau ist das? Da ich den proprietären NVIDIA-Treiber verwenden muss (für meine Dist gibt es kein offizielles 440-Treiber Release mehr) könnte ich tools wie nvidia-prime etc. nur selbst kompilieren oder mit einem Virtuellen Deb-Paket ("nvidia-treiber" präsent mit leerem deb-package gleichem Namens) zum Laufen bekommen.

Was heiße denn Funktioniert nicht?

Der LightDM Manager startet nicht einmal bis zum Login für die GUI! Nach dem booten bleibt das ganze auf der Console hängen (Boot Prozess ... LightDM X-Server hängt irgendwie "fest").

Im LightDM Logfile stand dann u.a. so etwas hier:
Zitat
GLib-GIO-CRITICAL **: Error while sending AddMatch() message

Meine letzte Verzweiflungstat war die i915 Treiber direkt im Kernel zu löschen - nachdem etliche Versuche mich der Intel Hybrid-GPU Kombi anzufreunden der den Treiber zu blacklisten fehl schlugen. Habe wirklich ALLES probiert. Eigentlich war ich gespannt, ob das mit dem Hybrid-Betrieb etwas bringt - aber bei soviel Frust verzichte ich dann doch lieber.

Nach dem löschen (umbenennen) der Treiber im Kernel kommt der Rechner nach Neustart zumindest bis zum LightDM-Login - dort hängt es nun aber. Ob das nun im Software-Treiber Modus oder schon über die NVIDIA-GPU läuft - ich bin mir nicht ganz sicher.

Zumindest auf der Konsole scheint die GPU zu laufen (mit den proprietären NVIDIA Treibern in Version 440.59).

Trotz löschen des XAuthority-File usw. kann ich mich allerdings bisher noch nicht einloggen ... ist ja leider ein Klassiker mit NVIDIA GPUs.


Apropos... Leider habe ich erst später erfahren, dass bei tuxedocomputers.com nahezu baugleiche Modelle wie die von Schenker verkauft werden mit Linux-Support.

Lüfter-Steuerung
Gibt es inzwischen eine Möglichkeit die Lüfter-Steuerung irgendwie ans laufen zu bekommen?

Nach meinem Kenntnisstand ist der verbaute Fan-Controller einfach "zu neu" für lm-sensors. Ich glaube aber der Chip ist bis auf die Bezeichnung/Kennung kompatibel zu einem ähnlichen Vorgänger-Modell. Gibt es hierzu irgendwelche Tipps? Auf GitHub habe ich im LM-Sensors Repository hierzu das Issue #219 eröffnet (Link für mich leider nicht erlaubt, da neuer User).

gkn

  • Einsteiger NB
  • Beiträge: 3
  • Karma: +0/-0
Re: Linux-Sammelthread
« Antwort #164 am: März 16, 2020, 15:55:21 »
Ich möchte zu meinem Thread oben zum Thema NVIDIA + Linux Probleme noch mal Feedback geben. Inzwischen habe ich es gelöst bekommen - allerdings nur, da ich im BIOS eine Möglichkeit gefunden habe die Intel GPU komplett zu deaktivieren!

Da ich mein Ubuntu Xenial (16.04 LTS) auf das neue XMG Pro 17 migriert habe standen dort keine aktuelleren Treiber für Ubuntu/Debian zur Verfügung.

Ich nutze aktuell die proprietären Treiber. Da der Installer einen meistens zwingt die GUI zu verlassen, habe ich hierfür nun ein Skript welches die Installation weitest gehend automatisiert. Ebenfalls wird ein Flag an den Installer übergeben, welcher die Installation während aktiver X11-Sitzung (Gnome, Unity, ...) erlaubt!

siehe GitHub Repository
github.com/typoworx-de/nvidia-proprietary-installer

In den Ordner Depot einfach die gewünschte, aktuelle NVIDIA-xxxx.run Datei herunter laden und das Skript ausführen.

----
Das Notebook läuft inzwischen recht gut. Für die Tastatur habe ich mir einen Clevo-Treiber geforked für den man die Notebook Modell-ID patchen muss. Ich teste das ganze gerade noch kann bei Interesse oder Usern die Mitwirken wollen dies gerne freigeben! Bitte einfach per PN melden bei Interesse mit zu entwickeln an einem Clevo-Treiber Fork für XMG Modelle.

Das ändern der Tastatur-LED farben ist mir übrigens trotz dieses Treiber noch nicht geglückt ...

Als Basis hat mir dieser Link übrigens sehr geholfen:
configurelaptop.eu/clevo-keyboard-backlight-control-for-linux/

----
Ein sehr nerviges Problem bleibt leider noch. Aktuell schaltet sich mein XMG Pro 17 gelegentlich spontan einfach aus! Und zwar sofort ohne Linux Shutdown!

Ich habe noch nicht heraus gefunden woran dies liegen kann. Die CPU Temperatur / Lüfter scheinen im normalen Rahmen zu laufen. Da ich das Gerät bereits zum Arbeiten nutze würde ich es auch ungerne einschicken.

Hat jemand einen Tipp hierzu? Ich habe in Grub nun auch die empfohlenen Kernel-Parameter "acpi_osi=! and acpi_osi=Linux" übernommen und hoffe dies hilft. Dies ist das einzige was aus meiner Sicht eventuell Probleme bereitet. Bei meinem vorherigen Notebook (ASUS G75V mit 1:1 dem selben Linux-System) hatte ich nie Probleme mit spontanem ausschalten des Systems.

 

 
C 2018 » Impressum     Sprachen: Deutsch | English | Español | Français | Italiano | Nederlands | Polski | Português | Русский | Türkçe | Svenska